Back to overview
Resolved

Companies House — Ongoing System Issue

Jun 10, 2026 at 11:01pm UTC  –  Jun 15, 2026 at 8:01am UTC
Affected services
kudocs.co.uk
Companies house (JSON API)
Companies house (Stream API)
Companies house (XML API)

Resolved
Jun 15, 2026 at 8:01am UTC

Maintenance ended

Created
Jun 10, 2026 at 11:01pm UTC

Companies House is currently experiencing an internal system issue affecting the processing of any submissions - via software filing (like Kudocs) web-filing or paper filing.

This includes same day filings.

They have been actively working on a fix over the weekend but have not been able to resolve the issue yet. The next update is expected at 4:00 PM.

We will keep this notice updated as we receive more information. You can also monitor Companies House service availability directly here:

https://www.gov.uk/government/organisations/companies-house/about/about-our-services#service-availability-and-planned-maintenance

Please contact Kudocs for more information.